Can't find confirmation button for latest All-in-one-SEO-pack Installation / Upgrading - All in One SEO Pack Forum

The support forums have a new home! Please visit All in One SEO Pack's new residence at Semper Plugins to purchase a support plan.

Please consider registering
guest

Log In

Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

   

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
Can't find confirmation button for latest All-in-one-SEO-pack
October 13, 2010
7:07 am
Alice
Guest

I upgraded the All-in-one-SEO-pack yesterday on my blog and enabled it in the admin page, but I couldn't find the confirmation button. Michael Torbert requested a screen shot, but can't find out how to upload the jpeg here. Anybody got the same problem, or an answer for uploading pictures?

October 13, 2010
7:49 am
Ridibund
Guest

Hello Alice,

There is an issue for older versions of WP in the file aioseop.class.php calling a function called get_post_types. I guess there will be a fix soon but you can get round this by removing the code from lines 2019-2060 in aioseop.class.php. This takes out the new Custom Post options

Nick

October 15, 2010
11:55 am
ogog
Guest

So where do you find that file to edit it???

Thanks.

October 15, 2010
2:21 pm
Ridibund
Guest

ogog said:

So where do you find that file to edit it???

Thanks.


Hello Alice,

Apologies for the techy gobbledygook.

Try this:

I have coded a simple fix for the problem which is in a file called aioseop.class.php. The fix is a new file that you can use to replace the one that comes with the plugin.

Download the new file I have put at http://www.mediafire.com/?f5v4…..is6o4zkyq0
Open it in a text editor.
Select all and copy all the code.

Go to the manage plugins page in WP.
Find All in One SEO Pack and click on the edit link underneath it.
In the editor look on the right for a menu listing all the files that make up the plugin.
Click on all-in-one-seo-pack/aioseop.class.php. This opens the code in the editor panel.

Replace all the code in the editor panel with the one downloaded from Mediafire. (Select all, paste)
Click Update file at bottom of the screen.
Go back to the All in One SEO menu under Settings and hopefully you should have all the options with an Update options button.

If it fails to work delete the plugin from the manage plugins page and start again.

I have tested this in a few WP installations 2.8.6 to 3.01 and hope it works for you. twitter.com/ridibund

October 17, 2010
3:57 pm
sinyo4u
Guest

can you help me…
when i click the edit button it shows me an error message
"Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 71 bytes) in /home/xxxx/public_html/wp-admin/includes/misc.php on line 278"

"xxxx" is my username

October 26, 2010
6:18 pm
Isha
Guest

Thank you. The fix worked for me.

Isha

October 31, 2010
7:27 pm
GeorgiaF
Guest

Got hermes erros and it practically blew up the website. Is this a PHP version problem?

October 31, 2010
11:41 pm
sbleaking
Guest

Ridibund said:

ogog said:

So where do you find that file to edit it???

Thanks.


Hello Alice,

Apologies for the techy gobbledygook.

Try this:

I have coded a simple fix for the problem which is in a file called aioseop.class.php. The fix is a new file that you can use to replace the one that comes with the plugin.

Download the new file I have put at http://www.mediafire.com/?f5v4…..is6o4zkyq0
Open it in a text editor.
Select all and copy all the code.

Go to the manage plugins page in WP.
Find All in One SEO Pack and click on the edit link underneath it.
In the editor look on the right for a menu listing all the files that make up the plugin.
Click on all-in-one-seo-pack/aioseop.class.php. This opens the code in the editor panel.

Replace all the code in the editor panel with the one downloaded from Mediafire. (Select all, paste)
Click Update file at bottom of the screen.
Go back to the All in One SEO menu under Settings and hopefully you should have all the options with an Update options button.

If it fails to work delete the plugin from the manage plugins page and start again.

I have tested this in a few WP installations 2.8.6 to 3.01 and hope it works for you. twitter.com/ridibund


THANK YOU SO MUCH!!!
You could not have explained it any better and made it any easier!

I thank you a millions times! BEST plugin out there!

November 3, 2010
2:34 pm
DiamondPointe
Guest

Ridibund said:

ogog said:

Hello Alice,

Apologies for the techy gobbledygook.

Try this:

I have coded a simple fix for the problem which is in a file called aioseop.class.php. The fix is a new file that you can use to replace the one that comes with the plugin.

Download the new file I have put at http://www.mediafire.com/?f5v4…..is6o4zkyq0
Open it in a text editor.
Select all and copy all the code.

Go to the manage plugins page in WP.
Find All in One SEO Pack and click on the edit link underneath it.
In the editor look on the right for a menu listing all the files that make up the plugin.
Click on all-in-one-seo-pack/aioseop.class.php. This opens the code in the editor panel.

Replace all the code in the editor panel with the one downloaded from Mediafire. (Select all, paste)
Click Update file at bottom of the screen.
Go back to the All in One SEO menu under Settings and hopefully you should have all the options with an Update options button.

If it fails to work delete the plugin from the manage plugins page and start again.

I have tested this in a few WP installations 2.8.6 to 3.01 and hope it works for you. twitter.com/ridibund


This method worked great for me. But instead of copying the contents of the file, I FTP'd the entire file to my website folder to overwrite the old one (after backing up the old file, of course). This is more technical, but it did the job.

Thank you, twitter.com/ridibund!

November 4, 2010
6:47 am
EUSP
Guest
10

Uploading the file through FTP worked for me. I had to refresh the admin page twice in order to get the buttons to show at the bottom, but after that, everything worked fine. Thanks -- Mark

November 15, 2010
11:30 pm
domeboys
Guest
11

Ridibund, I want to add my thanks for your explanation and fix. I had looked all over and had given up a couple of different times before I found this thread. It worked just as you said it would. Thank you!

Forum Timezone: America/New_York

Most Users Ever Online: 259

Currently Online:
16 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Michael Torbert: 2

Member Stats:

Guest Posters: 1561

Members: 6

Moderators: 0

Admins: 4

Forum Stats:

Groups: 5

Forums: 23

Topics: 1302

Posts: 3192

Newest Members: Nina Gerrero, Dawa

Administrators: WordPress Professional (478), hallsofmontezuma (202), onefinejay (10), stevemortiboy (4)